rename 'numerical' to 'datatype'?

Today i started wondering if it would be better to rename the 'numerical' optionmeta (currently in CVS) to something like 'datatype' to make it easier to add other types in the future, by reusing the same option meta.
By example: when an option currently must be numerical it uses: numerical=true. Suppose in the feature we want to add the possibility to create options taht only accept dates. Then we shouldadd yet another optionmeta: datetime=true. So wouldn't it be better to rename 'numerical' to 'datatype' and set this to 'numerical' for numerical options? Doing it this way we could in the future simply add new datatypes: dataype=numerical , datatype=datetime , datatype=url ...



karma on 2004-09-19 15:04 reply

Good thinking. Better change

Good thinking. Better change it before everyone is using numerical=true

Comment Atom Feed